New ccMiner 1.0 Available with Added Support for X11 Mining

10 May
2014

ccminer-1-0-x11-support

The ccMiner software miner for Nvidia GPUs has received another update of the source code this time adding support for the X11 algorithm for GPU mining crypto currencies such as DarkCoin. We have compiled a binary for Windows that you can find below and try on your Nvidia GPU. It seems that the performance that the current code for X11 offers on Nvidia hardware is pretty similar to what you can get on AMD. On a GeForce GTX 780 Ti we are getting hashrate of about 2.8 MHS when mining DarkCoin.

Do note that the windows binary you can download below is compiled for Computer 3.0, 3.5 and 5.0 cards (32-bit version only), so it will not work on older cards. It is also compiled with Visual Studio 2012, so if you do not already have Visual C++ Redistributable for Visual Studio 2012 you will have to download and install it.

To download the latest CCminer 1.0 with added support for X11 algorithm for Windows OS…



Other Similar Publications:

20 Responses to New ccMiner 1.0 Available with Added Support for X11 Mining

Larry

May 10th, 2014 at 17:55

Hi,

I am using this build to mine Darkcoin @ drkpool.com. However, it’s not accepting shares. Any idea?

Vytas

May 10th, 2014 at 18:23

Tried this on darkpool.io – seems to hash on 560TI, but the pool does not see any shares submitted on the other end.

admin

May 10th, 2014 at 19:33

X11 support is new and there could be some issues with it. There is now also an official windows binary release, you can try with it as well: https://github.com/cbuchner1/ccminer/releases/download/v1.0/ccminer-v1.0.zip

Vytas

May 10th, 2014 at 20:16

the ccminer-v1.0 from gitbub does seem to have the same issue…
Anyone else tried it with pool.darkcoin.io:3333 ?

Guy

May 10th, 2014 at 23:24

Been running for a few hours without issue on a GTX 770(ccminer30). I’m using stratum1.suchpool.pw:3335. The hashrate is great at 2.370 MHs, that’s better than what I can do my R9 280xs. My Gtx 660 isn’t so lucky though, it only works for a short time. After a few accepts, I get some kind of incredible hashrate (millions of khashes) then it just waits…

John

May 11th, 2014 at 00:31

Can someone provide a build for Compute 2.0? Thanks

d

May 11th, 2014 at 05:15

@John: from the ccminer readme.txt “Support for Compute 2.0 has been dropped so we can more efficiently implement new algorithms using the latest hardware features.”

ubunthero

May 11th, 2014 at 13:00

X11 Mining isn’t working for me, I’ve tried on different pools and blocks are detected, kh/s is displayed but it doesn’t tell me that blocks are accepted…

Vytas

May 11th, 2014 at 16:20

Hi again,

I tried this on 750 Ti – works, 1.5 Mhs/card.

So, it simply does not support CUDA Compute Capability <3.0

Alec

May 11th, 2014 at 21:10

When I try to run the Miner I get a missing file error? How can that be solved? MSVCP110.dll is missing

d

May 12th, 2014 at 03:09

@Alec: Have you downloaded/installed the Visual C++ Redistributable for Visual Studio 2012 as stated in the post? That missing .dll seems to be related to not having the proper redistributable installed.

Robin

May 12th, 2014 at 04:58

I keep getting this message.

“GPU #0: result for nonce $05CB1EB5 does not validate on CPU”

how the heck do i fix it?

My settings:

setx GPU_MAX_ALLOC_PERCENT 100
ccminer30.exe –algo=x11 -o stratum+tcp://useast.blackcoinpool.com:3333 -u myworker -p mypass

please write to my email if u can help

Jason

May 14th, 2014 at 02:01

There’s a version of ccminer available at this link that works with compute 2.0,
https://bitcointalk.org/index.php?topic=167229.msg6676746#msg6676746

I’m running it on a GTX 560 Ti and getting 1400 kh/s at stock clock speeds. Pretty good considering my 750 Ti’s are doing about 1700 kh/s.

energy

May 15th, 2014 at 02:44

Thanks to Guy! I am up and running on GTX770 2.7MH/s ~ 2.8MH/s
Using: stratum1.suchpool.pw:3335

Guy

May 15th, 2014 at 06:31

Got my GTX660 running stable at 1.4 MHs using Jason’s link up here.

Alec Kloss

May 19th, 2014 at 09:01

Got the DLL worked out, be sure to download the X86 package from windows. The program runs great now, however my pool doesn’t see any of my hash rate.

admin

May 19th, 2014 at 09:21

Alec, make sure you are starting the right version of ccminer for your hardware, based on the Compute version support of the GPU you have.

DoesNotCompute

May 23rd, 2014 at 03:00

Thank you admin! I was also getting same error as Alec Kloss, this link will give good table for the Cuda level of your GPU
http://en.wikipedia.org/wiki/CUDA

Jackboy

May 26th, 2014 at 21:23

What is error “GPU #0: result for nonce $0496DBA9 does not validate on CPU!” mean?
I am running ccminer30.exe with NVidia 670 on Windows 8.1 with I7 Ivy Bridge CPU. It is hashing at about 2.0MH/s and everything is fine EXCEPT ‘nonce’ error CPU. ???? Thanks for any input.

David

May 28th, 2014 at 00:57

Does this version not work on XP. I get “not valid 32 bit app” when I try to tart it.

Leave a Reply

Your email address will not be published. Required fields are marked *

top